De functie AANTAL.ALS in Excel

| Gerard

Ik heb al eerder artikelen geschreven over de Functie ALS en de geneste ALS functie in Excel.

In dit artikel behandel ik de AANTAL.ALS functie.

Stel je bent een bedrijfsleider in een supermarkt. In een Excel bestand hou je bij of je personeelsleden op tijd komen.

Je wilt nu graag een mooi overzicht maken waarin je in een oogopslag ziet wie er te laat was, en hoeveel mensen in totaal te laat zijn gekomen.

Je tabel ziet er in eerste instantie zo uit:

AANTAL.ALS functie in Excel

Iedereen die na 9 uur aanwezig is, is te laat in dit voorbeeld.

Zoals gezegd wil je graag in een oogopslag zien wie te laat is. Dit gaan we doen aan de hand van de voorwaardelijke opmaak.

Selecteer eerst cel B2 tot en met cel B9 en ga daarna in je werkbalk naar ”opmaak” en klik op ”voorwaardelijke opmaak”:

AANTAL.ALS functie in Excel

Klik vervolgens op + (een nieuwe regel toevoegen).

Je komt dan in het venster van de voorwaardelijke opmaak, kies hier bij stijl voor ”klassiek”

Stap 1: selecteer ”Alleen cellen opmaken die deze waarde bevatten”

Stap 2: selecteer ”Celwaarde” ”is groter dan” ”09:00”

Stap 3: selecteer ”rode opvullen met rode tekst”

AANTAL.ALS functie in Excel

Je nieuwe regel is toegevoegd, als je celbereik klopt, klik je op ”ok”:

AANTAL.ALS functie in Excel

Nu zie je direct wie te laat was:

AANTAL.ALS functie in Excel

In dit voorbeeld zijn er 8 personeelsleden, dus zie je ook direct dat drie mensen te laat waren.

Maar als je honderd personeelsleden hebt, zie je dat minder snel. Daarom gaan we gebruik maken van nog een formule, namelijk de ALS functie:

=AANTAL.ALS(bereik;criterium)

We vullen deze formule in cel C2.

In dit voorbeeld is het bereik B2:B9 en het criterium >09:00 (groter dan 9 uur dus)

Dit wordt dus:

=AANTAL.ALS(B2:B9;”>09:00″)

Let op dat je aanhalingstekens gebruikt in de formule.

AANTAL.ALS functie in Excel

En zoals je ziet heeft de AANTAL.ALS functie berekend dat er 3 personeelsleden te laat waren.

Ontwikkel je Excel vaardigheden met onze online Excel cursussen en haal meer uit Excel!

3 gedachten over “De functie AANTAL.ALS in Excel”

  1. Wij coderen voorwerpen met een hoofdletter of een kleine letter. Hoe kan ‘aantal.als’ voorwerpen met een kleine letter optellen bij elkaar? (Hoofdlettergevoelig zoeken lukt Excel wel.)

    Beantwoorden
    • ”Zijn namen hoofdlettergevoelig?
      Namen kunnen uit hoofdletters en kleine letters bestaan. In Microsoft Excel wordt bij namen geen onderscheid gemaakt tussen hoofdletters en kleine letters. Als u bijvoorbeeld de naam Verkoop hebt gemaakt en in dezelfde werkmap de naam VERKOOP definieert, wordt de eerste naam door de tweede vervangen.”
      – Dit stukje uit Help 2003 biedt weinig hoop. –

      Beantwoorden
  2. ik blijft foutmeldingen krijgen, zelfs als ik de letterlijke formule van u kopieër. Telkens als ik een dubbele punt gebruik in een formule wilt ie hem niet meer pakken. enig advies?

    Beantwoorden

Plaats een reactie