Tellen hoe vaak een waarde voorkomt in Excel

Gepubliceerd op

In dit artikel leer je hoe je met behulp van de functie AANTAL.ALS kunt tellen hoe vaak een bepaalde waarde voorkomt in een reeks met gegevens.

De functie AANTAL.ALS is een logische functie. Dit houdt in dat Excel het aantal cellen in een bereik telt die voldoen aan een bepaalde voorwaarde.

Eerst wordt uitgelegd hoe de functie werkt en daarna zal aan de hand van meerdere voorbeelden worden laten zien hoe je dit in de praktijk kunt toepassen.

Hoe werkt de functie AANTAL.ALS

De schrijfwijze van de formule is =AANTAL.ALS(bereik;criterium)

Zoals je kunt zien heeft deze formule 2 argumenten.

  • Bereik – hier verwijs je naar het bereik van cellen waarin je wilt tellen hoe vaak de waarde voorkomt.
  • Criterium – hier vul je de waarde in die je wilt laten optellen.

Wanneer je een woord of tekst reeks als criterium wilt gebruiken is het belangrijk dat je de tekst tussen dubbele aanhalingstekens plaatst.

Voorbeeld 1: tellen hoe vaak een woord voorkomt in Excel

Stel je hebt een lijst met namen in het celbereik A2:A16 en je wilt tellen hoe vaak de naam ”Sophie” voorkomt.

  1. Selecteer eerst de cel waarin je de uitkomst wilt tonen. In dit voorbeeld is dat cel D2
  2. Typ een isteken (=) om aan te geven dat er een formule volgt
  3. Typ de functienaam AANTAL.ALS(
  4. Selecteer het bereik met namen. In dit voorbeeld is dat A2:A16
  5. Typ een puntkomma (;) om aan te geven dat er volgend argument volgt
  6. Typ het woord dat je wilt tellen tussen dubbele aanhalingstekens. In dit voorbeeld is dat dus “Sophie”
  7. Sluit de formule met een haakje )
  8. Druk op Enter op de formule in te voeren

Zoals je ziet laat Excel meteen weten dat de naam Sophie 3x voorkomt in de reeks met waarden. Dit is erg handig wanneer je moet werken in een groot Excel bestand en snel wilt weten hoe vaak een woord of een reeks woorden voorkomt in een bepaald bereik.

Voorbeeld 2: Tellen hoe vaak een getal voorkomt in Excel

Je kunt deze functie ook gebruiken om te tellen hoe vaak een getal voorkomt in Excel. Dit werkt op dezelfde manier, alleen verandert het criterium.

In bovenstaand voorbeeld telt Excel hoe vaak het getal 15 voorkomt in het bereik A2:A16. Omdat het criterium enkel een getal bevat hoeft het niet tussen dubbele aanhalingstekens geschreven te worden zoals bij voorbeeld 1 wel het geval is.

Je kunt er ook voor kiezen om vergelijkingsoperatoren in het criterium te gebruiken. Stel je wilt weten hoeveel getallen er in het bereik voorkomen die groter zijn dan 25.

In Excel is > het symbool voor groter dan. In dit voorbeeld wordt het criterium dus >25 en omdat er een teken in voorkomt is het belangrijk dat je dit argument tussen dubbele aanhalingstekens schrijft.

De formule wordt dan dus =AANTAL.ALS(A2:A16;”>25″)

Het resultaat is dat in dit bereik 5 getallen voorkomen die groter zijn dan 25.

Hoi, ik ben Gerard

In 2013 ben ik deze blog over Excel begonnen. Het doel van Handleiding Excel is om jou te helpen beter te worden in Excel.

Excel templates

Bespaar tijd met vooraf ontworpen Excel templates

Urenregistratie

Kasboek

Bekijk templates

Plaats een reactie