Aantal argumenten in Excel

| Gerard

Je hebt in je administratie in Excel een tabel opgenomen van je voorraad. Je wilt nu weten hoeveel verschillende artikelen je hebt. Dat kun je heel makkelijke doen met de formule van “aantal argumenten”. De functie telt het aantal niet-lege cellen in een bereik.

De formule:

AANTALARG(bereik 1;bereik 2;…)

Bijvoorbeeld: =AANTALARG(B6:B10)

Waar moet je op letten:

Met deze functie worden alle cellen geteld die enige vorm van informatie bevatten, dus ook foutwaarden zoals #DEEL/0! of een cel met de inhoud “ “. Een lege cel wordt niet geteld.

Wil je alleen die cellen tellen die getallen of letters bevatten gebruik dan de formule “Aantal”’.

Wil je alleen die cellen tellen die aan een bepaalde voorwaarde voldoet gebruik dan de formule “Aantal.als”.

Voorbeeld:

Van onderstaande tabel wil je weten hoeveel verschillende producten je hebt.

Aantal argumenten in Excel

Plaats in de cel waar je je uitkomst wilt uitlezen (cel B5) de formule =AANTALARG(B6:B10).

Aantal argumenten in Excel

Het maximaal aantal rijen bedraagt 255. Heb je er meer, geef dan een tweede bereik op.

 

Ontwikkel je Excel vaardigheden met onze online Excel cursussen en haal meer uit Excel!

1 gedachte over “Aantal argumenten in Excel”

  1. Hi,

    Ik heb een klein probleempje. Ik heb 1 criteria maar meerdere bereik.
    Ik heb deze formule gemaakt: =AANTAL.ALS(P60:P65;O291)
    Deze formule doet het perfect, maar nu wil ik mee bereik toevoegen, dus ik heb het volgende gedaan: =AANTAL.ALS(P60:P65;O291) + AANTAL.ALS(P128:P153;O291) + AANTAL.ALS(P162:P171;O291) + AANTAL.ALS(P198:P171;O226) Maar dit pakt die helaas niet. Als ik 1 bereik weg haal dan pakt die het wel. Maar zodra ik vier keer een bereik doen met een criteria dan werkt de formule het niet

    Beantwoorden

Plaats een reactie