Geneste ALS functie in Excel

| Gerard

In dit artikel leg ik je uit wat een geneste ALS functie inhoudt en hoe je deze functie kunt gebruiken.

In een eerder artikel kun je lezen hoe de standaard ALS functie werkt.

Een geneste ALS-functie betekent dat je een ALS-functie gebruikt binnen een andere functie. Hierdoor kun je verschillende criteria testen en het aantal mogelijke resultaten vergroten.

Met de volgende stappen maak je een formule van de geneste ALS functie:

Stap 1: Selecteer de cel waarin je het antwoord wilt hebben

Stap 2: Typ: =ALS(

Stap 3: Typ de logische test (de voorwaarde)

Stap 4: Typ wat Excel moet doen als de eerste voorwaarde waar is

Stap 5: Als de eerste voorwaarde onwaar is, dan moet Excel naar de volgende voorwaarde gaan. Deze begint altijd weer met =ALS(

Stap 6: Typ de tweede voorwaarde, gevolgd door een ;

Stap 7: Indien de tweede voorwaarde ook onjuist is, gaat Excel de volgende voorwaarde toepassen. Dit proces wordt herhaald tot Excel bij de laatste voorwaarde is uitgekomen

Stap 8: Aan het eind van de formule gebruik je de laatste voorwaarde

Stap 9: Typ wat Excel moet doen als de laatste voorwaarde juist is

Stap 10: Typ wat Excel moet doen als de laatste voorwaarde onjuist is

Stap 11: Je moet een haakje aan het einde van de geneste ALS typen voor elke logische test die je hebt ingevoerd.

Zoals je ziet is deze functie wat lastiger dan de normale ALS functie. Ik hoop dat het aan de hand van een voorbeeld duidelijker wordt zodat jij ook gemakkelijk de geneste ALS functie kunt gebruiken.

Voorbeeld geneste ALS functie

Stel je bent een docent en je hebt een puntenlijst van je leerlingen. Je wilt hierbij snel een overzicht creëren met de waardering per leerling.

Je werkblad ziet er bijvoorbeeld zo uit:

Geneste ALS functie in Excel

In dit voorbeeld selecteren we cel C2 en voeren daar de formule in.

De formule werkt als volgt: 

Als de waarde van cel B2 kleiner of gelijk is aan 55 geeft Excel het resultaat “Onvoldoende”.

Als de waarde van cel B2 kleiner of gelijk is aan 70 geeft Excel het resultaat “Voldoende”.

Als de waarde van cel B2 kleiner of gelijk is aan 85 geeft Excel het resultaat “Goed”, anders geeft Excel het resultaat “Perfect”.

Je maakt hierbij gebruik van de volgende tekens:

geneste als functie excel

Je krijgt dan de volgende formule:

=ALS(B2<=55;”Onvoldoende”;ALS(B2<=70;”Voldoende”;ALS(B2<=85;”Goed”;”Perfect”)))

Die voer je in cel C2 in:

Geneste ALS functie in Excel

Vervolgens kopieer je deze formule en selecteer je de cellen C3 t/m C8:

Geneste ALS functie in Excel

Daar plak je vervolgens de formule die je zojuist hebt gekopieerd. En dan krijg je:

Geneste ALS functie in Excel

Ontwikkel je Excel vaardigheden met onze online Excel cursussen en haal meer uit Excel!

1 gedachte over “Geneste ALS functie in Excel”

  1. Beste

    Ik heb een lijst gemaakt met artikelnummer en prijzen, ook een foto van van het artikel
    Als ik via VLOOKUP wil zien in een bepaald magazijn over welk artikel het gaat (de foto) krijg in 0 in de tabel.
    Hoe kan Excel foto opvragen via VLOOKUP

    Beantwoorden

Plaats een reactie