Functie AANTALLEN.ALS in Excel

Omschrijving

De functie AANTALLEN.ALS werkt in principe hetzelfde als de functie AANTAL.ALS maar dan met meerdere bereiken en criteria.

Excel telt dus in meerdere bereiken de waarden op die aan meerdere criteria voldoen.

Schrijfwijze

AANTALLEN.ALS(criteriumbereik;criteria;…)

De functie AANTALLEN.ALS heeft de volgende argumenten:

Criteriabereik 1Het bereik waarin de bijbehorende criteria worden geëvalueerd.
Voorwaarde 1De voorwaarde in de vorm van een getal, expressie, cel-verwijzing of tekst op basis waarvan wordt bepaald welke cellen worden geteld. Een voorwaarde kan bijvoorbeeld zijn 32, “>32”, B4, “appels” of “32”.
Criteriabereik 2Je kunt hier een tweede bereik toevoegen. Dit is volledig optioneel.
Voorwaarde 2Je kunt hier een tweede voorwaarde toevoegen. Dit is volledig optioneel.

Je kunt deze formule gebruiken aan de hand van de volgende stappen:

  1. Selecteer een cel waar je de uitkomst wilt tonen
  2. Typ =AANTALLEN.ALS(
  3. Typ of selecteer het bereik
  4. Typ ;
  5. Typ de voorwaarde tussen ‘’ ‘’
  6. Typ ;
  7. Typ of selecteer het bereik
  8. Typ de voorwaarde tussen ‘’ ‘’
  9. Herhaal stap 6 t/m 8 zo vaak als je wilt
  10. Sluit af met een )

Voorbeeld

Ik zal dit aan de hand van een voorbeeld uitleggen.

Je houdt in Excel van een aantal verengingen bij in welke regio ze liggen en hoeveel leden ze hebben. Je wilt graag per regio weten hoeveel verenigingen meer dan 200 leden hebben.

Voor zo’n vraagstuk is de functie AANTALLEN.ALS ideaal.

Je werkblad ziet er bijvoorbeeld uit zoals in figuur 1.

Functie AANTAL.ALS in Excel
Figuur 1

Het eerste bereik wordt dan B2:B15 en het criteria Groningen.

Het tweede bereik wordt C2:C15 en het criteria >200.

De formule wordt dan:

=AANTALLEN.ALS(B2:B15;’’Groningen’’;C2:C15;’’>200’’)

Excel telt dan alle verenigingen op uit de regio Groningen met meer dan 200 leden.

Functie AANTAL.ALS in Excel
Figuur 2

Vervolgens doe je hetzelfde in cel F3 en F4 met de regio’s Drenthe en Friesland.

Functie AANTAL.ALS in Excel
Figuur 3

Als je deze formule hebt gemaakt met behulp van de formulebouwer ziet je venster er zo uit:

Functie AANTAL.ALS in Excel
Figuur 4

Ontwikkel je Excel vaardigheden met onze online Excel cursussen en haal meer uit Excel!

11 gedachten over “Functie AANTALLEN.ALS in Excel”

  1. Uitleg is helder, alleen loop ik ergens anders tegenaan:
    In een kolom heb ik een omschrijving, zoals provincienaam in jouw voorbeeld en in de andere kolom staan datums. De criteria bij mij moeten zijn:
    Eerste bereik: omschrijving
    Tweede bereik: valt binnen een bepaalde periode (dus bijvoorbeeld binnen augustus 2019).
    Om het makkelijker te maken (dacht ik) zet ik de begin-en einddatum van de periode bovenin de kolom en verwijs daarnaar, dus data in bereik moeten groter zijn dan begindatum en kleiner dan einddatum.
    Ik krijg steevast 0 als resultaat.
    Alleen op omschrijving zoeken in aantal.als of aantallen.als leidt wel tot een resultaat. Alleen op datum zoeken lukt wel met somproduct. Kunnen deze twee op een of andere manier worden gecombineerd?

    Beantwoorden
  2. Ik heb een soort gelijke uitdaging.
    Situatie: 1 excelbestand, 8 werkbladen genaamd week 1 , week 2 t/m week 8, Op ieder werkblad heb ik een aantal cellen met waarde die hoger of gelijk 5 moeten zijn.
    Ik wil graag een functie die op een totaaloverzicht tabblad weergeeft of de cellen B5 tm F5 voldoen aan de criteria 5;”prima”;'”helaas”)

    Beantwoorden
  3. Bedankt voor deze heldere uitleg, ik heb hierover nog een vraag waar ik niet uitkom. Is het mogelijk om deze formule te kopiëren op een manier dat het “criteriumbereik” vast staat, maar dat het “criterium” wel mee-veranderd.

    Ik heb nu zelf de volgende formule: =AANTAL.ALS(Y2:Y4000;J2)
    Als ik deze kopieër naar het uitvoervak eronder veranderd de formule
    automatisch in: =AANTAL.ALS(Y3:Y4001;J3)
    Het is goed dat de voorwaarde/criterium één cel naar onder gaat (J3), maar ik zou graag willen dat het Criteriabereik Y2:Y4000 hetzelfde blijft.
    Weet iemand hier misschien hoe ik dit voor elkaar kan krijgen?

    Zou heel fijn zijn.

    Beantwoorden
  4. Is het ook mogelijk om een Aantal.als formule te maken die aantallen telt in andere tabbladen of zelfs in andere bestanden?

    Beantwoorden
  5. Hallo,
    ik ben op zoek naar een formule om een waarde in cellen op te tellen, hiervoor heb je =AANTAL.ALS maar ik ben dit met voetbal scores aan het doen.
    dus ik wil in een competitie optellen hoe vaak bijv. de score 0 0 voorkomt.
    maar ik heb de 0 in een cel en de andere 0 in een andere cel, dus niet samen in 1 cel anders was het makkelijk optellen.
    Maar vanwege andere formules voor andere dingen uit te zoeken moet ik de beide 0 in een aparte cel hebben naast elkaar.

    ik kan helaas geen afbeelding hier achterlaten.

    Beantwoorden
  6. Beste Gerard, ik heb de volgende formule

    =AANTALLEN.ALS(Actielijst!$A$1:$A$5000;”>=”&DATUM(A1;A1;A1);Actielijst!$A$1:$A$5000;”<="&DATUM(B1;B1;B1);Actielijst!$E$1:$E$5000;Overzichtspagina!A6)

    Op actielijst heb ik mijn gegevens staan (input). Hier staat bijvoorbeeld "telefoon" of "mail". In kolom E van actielijst staan deze opgesomd. Nu wil ik in de formule dat die de aantallen tussen een bepaalde datum (overzichtspagina is A1 begindatum en B1 einddatum) de aantal keren "Telefoon"optelt.

    Kan dit met aantal.als of aantallen.als? Want heb de formule verschillende keren herschreven, volgorde aangepast maar krijg telkens "0" te staan

    Beantwoorden

Plaats een reactie